FC2ブログ


2014年12月26日 (金) | Edit |
Ruby 2.2.0登場
http://news.mynavi.jp/news/2014/12/26/211/
Rubyコミュニティは12月25日(米国時間)、「Ruby 2.2.0 Released」においてRubyの最新版となる「Ruby 2.2.0」を公開したと伝えた。Ruby 2.2.0は多くの新機能や機能改善が実施されているが、特にガベージコレクタの改良が注目されるバージョンとなっており、Rails 5.0以降は今回リリースされたバージョンが要求されている。Ruby 2.2.0よりも前のバージョンのRubyのガベージコレクタはシンボルタイプオブジェクトをガベージコレクトの対象として扱ってこなかった。Ruby 2.2.0のガベージコレクタはシンボルタイプオブジェクトもガベージコレクタの対象としており、これまでのバージョンと比較してシンボルが使用するメモリ容量が削減されている。Rails 5.0はシンボルタイプオブジェクトもガベージコレクタの対象とすることを求めているため、Rails 5.0を動作させるにはRuby 2.2.0ないしはこれ以降のバージョンのRubyが必須となる
ということです。日本発のRubyがんばってほしいぞ。